The Zombie Cable Box

I’m almost certain that none of my readers have any interest whatsoever in my cable box project, but I had a development this weekend. I’d love to be running MythTV, but since Cablevision insists on putting the Copy Once flag on about 2/3 of the channels I get, so that’s not practical for me (I pine for FiOS still…). Thus, I am stuck with Windows Media Center, which itself isn’t the worst thing ever because WMC is actually an excellent frontend when it works.

The problem, as you might have guessed, is that it hasn’t been working.

About three weeks ago, I installed a heatsink on my DVR, and apparently it got stuck in a boot loop after a botched patch. I was hoping to be able to restore it, because recordings with the copy once flag wouldn’t play on a rebuild.¬†However, after about three hours of poking at it, no dice, so a rebuild it was.

I reinstalled Windows 7, let it sit to download its updates…and then I got back into the boot loop issue again. I then tried Windows Vista (with 5GB of RAM, an actual GPU, an SSD, and a 3.4GHz Core 2 Duo, it’s actually quite usable), which worked wonderfully..except it doesn’t support my HDHomeRun Prime¬†properly. I would’ve gone to Windows 8, but apparently it’s not possible to activate a Media Pack serial number anymore, even though I already have one.

So, I managed to find a place on the internet (not the shady side of the internet, a forum for people like me) where the procedures were found to get Media Center running on Windows 10. It took two installations of Win10 to do it, and I still have to tweak my firewall to only allow it to get guide data (not a fan of Win10 Telemetry), but I finally have my cable box back up and running again.

2 thoughts on “The Zombie Cable Box

  1. Soooo, you had to install Windows 10, did you? Interesting considering the fact that you felt there was no point to it. LOL (inside joke).

    1. Yes, Windows 10 solved my problem in this particular case. There is no functionality that is new in Windows 10 (aside from “not getting stuck in a boot loop) that is in use on my cable box. If Windows 7 was stable on the cable box, I wouldn’t have bothered, because Windows 7 was functionally complete in this appliance-like context.

Leave a Reply

Your email address will not be published. Required fields are marked *

Facebook Auto Publish Powered By : XYZScripts.com
x Shield Logo
This Site Is Protected By
The Shield →